libxmlccwrap_0.0.12-1.diff.gz
[obi/libxmlccwrap.git] / configure.ac
1 dnl Ensure that this file is processed with autoconf 2.50 or newer
2 dnl Don't even think about removing this check!
3 AC_PREREQ(2.50)
4
5 AC_INIT(Makefile.am)
6
7 AM_INIT_AUTOMAKE(libxmlccwrap,0.0.12)
8
9 AC_PROG_CXX
10 AC_LANG_CPLUSPLUS
11 AC_PROG_INSTALL
12
13 AC_DISABLE_STATIC
14 AC_PROG_LIBTOOL
15 AM_PROG_LIBTOOL
16
17 AC_CHECK_LIB(xml2,main)
18 AC_CHECK_LIB(xslt,main)
19
20 AC_OUTPUT([Makefile \
21           xmlccwrap/Makefile \
22           html/Makefile \
23           html/pics/Makefile \
24           testlib/Makefile ])
25           
26 echo "
27 $PACKAGE $VERSION
28 configuration:
29 --------------
30
31  compiler ....... : ${CXX} 
32  --prefix ....... : ${prefix}
33  --exec-prefix .. : ${exec_prefix}
34  
35
36  Now type 'make' to build $PACKAGE $VERSION.
37 "