Updated upstream Git repositories
[opendreambox.git] / meta-dreambox / recipes-kernel / linux / linux-dreambox-3.4 / 0001-BRCMSTB-dont-enable-new-i2c-driver-by-default.-it-co.patch
1 From add2583cd20a9f9ea45798a7bc56795b7251706b Mon Sep 17 00:00:00 2001
2 From: Andreas Monzner <andreas.monzner@dream-property.net>
3 Date: Thu, 8 Dec 2016 17:14:45 +0100
4 Subject: [PATCH] BRCMSTB: dont enable new i2c driver by default.. it conflicts
5  with our own i2c driver
6
7 ---
8  drivers/i2c/busses/Kconfig | 2 +-
9  1 file changed, 1 insertion(+), 1 deletion(-)
10
11 diff --git a/drivers/i2c/busses/Kconfig b/drivers/i2c/busses/Kconfig
12 index af20b37..b36ba9a 100644
13 --- a/drivers/i2c/busses/Kconfig
14 +++ b/drivers/i2c/busses/Kconfig
15 @@ -918,7 +918,7 @@ config SCx200_ACB
16  config I2C_BRCMSTB
17         tristate "BRCM Settop I2C adapter"
18         depends on BRCMSTB
19 -       default y
20 +       default m
21         help
22           If you say yes to this option, support will be included for the
23           I2C interface on the Broadcom Settop SoCs.
24 -- 
25 2.1.4
26