swapped checksums
[opendreambox.git] / meta-opendreambox / recipes-connectivity / openssl / openssl-0.9.8u / debian / version-script.patch
1 Upstream-Status: Backport [debian]
2
3 Index: openssl-0.9.8m/Configure
4 ===================================================================
5 --- openssl-0.9.8m.orig/Configure       2010-02-27 12:28:32.000000000 +0100
6 +++ openssl-0.9.8m/Configure    2010-02-27 12:28:35.000000000 +0100
7 @@ -1512,6 +1512,8 @@
8                 }
9         }
10  
11 +$shared_ldflag .= " -Wl,--version-script=openssl.ld";
12 +
13  open(IN,'<Makefile.org') || die "unable to read Makefile.org:$!\n";
14  unlink("$Makefile.new") || die "unable to remove old $Makefile.new:$!\n" if -e "$Makefile.new";
15  open(OUT,">$Makefile.new") || die "unable to create $Makefile.new:$!\n";
16 Index: openssl-0.9.8m/openssl.ld
17 ===================================================================
18 --- /dev/null   1970-01-01 00:00:00.000000000 +0000
19 +++ openssl-0.9.8m/openssl.ld   2010-02-27 12:28:35.000000000 +0100
20 @@ -0,0 +1,5 @@
21 +OPENSSL_0.9.8 {
22 +        global:
23 +                *;
24 +};
25 +
26 Index: openssl-0.9.8m/engines/openssl.ld
27 ===================================================================
28 --- /dev/null   1970-01-01 00:00:00.000000000 +0000
29 +++ openssl-0.9.8m/engines/openssl.ld   2010-02-27 12:28:35.000000000 +0100
30 @@ -0,0 +1,5 @@
31 +OPENSSL_0.9.8 {
32 +        global:
33 +                *;
34 +};
35 +