Updated upstream Git repositories
[opendreambox.git] / meta-opendreambox / recipes-connectivity / openssl / openssl-0.9.8y / debian / pkg-config.patch
1 Upstream-Status: Backport [debian]
2
3 Index: openssl-0.9.8k/Makefile.org
4 ===================================================================
5 --- openssl-0.9.8k.orig/Makefile.org    2009-07-19 11:34:56.000000000 +0200
6 +++ openssl-0.9.8k/Makefile.org 2009-07-19 11:36:02.000000000 +0200
7 @@ -444,7 +444,8 @@
8             echo 'Description: OpenSSL cryptography library'; \
9             echo 'Version: '$(VERSION); \
10             echo 'Requires: '; \
11 -           echo 'Libs: -L$${libdir} -lcrypto $(EX_LIBS)'; \
12 +           echo 'Libs: -L$${libdir} -lcrypto'; \
13 +           echo 'Libs.private: $(EX_LIBS)'; \
14             echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libcrypto.pc
15  
16  libssl.pc: Makefile
17 @@ -457,7 +458,8 @@
18             echo 'Description: Secure Sockets Layer and cryptography libraries'; \
19             echo 'Version: '$(VERSION); \
20             echo 'Requires: '; \
21 -           echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
22 +           echo 'Libs: -L$${libdir} -lssl'; \
23 +           echo 'Libs.private: -lcrypto $(EX_LIBS)'; \
24             echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > libssl.pc
25  
26  openssl.pc: Makefile
27 @@ -470,7 +472,8 @@
28             echo 'Description: Secure Sockets Layer and cryptography libraries and tools'; \
29             echo 'Version: '$(VERSION); \
30             echo 'Requires: '; \
31 -           echo 'Libs: -L$${libdir} -lssl -lcrypto $(EX_LIBS)'; \
32 +           echo 'Libs: -L$${libdir} -lssl -lcrypto'; \
33 +           echo 'Libs.private: $(EX_LIBS)'; \
34             echo 'Cflags: -I$${includedir} $(KRB5_INCLUDES)' ) > openssl.pc
35  
36  Makefile: Makefile.org Configure config