tzdata: update bbappend for 2013i
[opendreambox.git] / meta-opendreambox / recipes-devtools / opkg / opkg / 0001-Don-t-mark-Conflicts-as-Depends.patch
1 From cd93b79fe14a6f2f90f39c9c83d789166ca9e532 Mon Sep 17 00:00:00 2001
2 From: Andreas Oberritter <obi@opendreambox.org>
3 Date: Wed, 16 May 2012 23:29:04 +0200
4 Subject: [PATCH 01/19] Don't mark Conflicts as Depends
5 To: opkg-devel@googlegroups.com
6 Cc: paul@paulbarker.me.uk
7
8 - Fixes 'whatconflicts' sub-command.
9
10 Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
11 ---
12  libopkg/pkg_depends.c | 2 +-
13  1 file changed, 1 insertion(+), 1 deletion(-)
14
15 diff --git a/libopkg/pkg_depends.c b/libopkg/pkg_depends.c
16 index a4df7de..4664d4e 100644
17 --- a/libopkg/pkg_depends.c
18 +++ b/libopkg/pkg_depends.c
19 @@ -691,8 +691,8 @@ void buildConflicts(pkg_t * pkg)
20  
21      conflicts = pkg->conflicts = xcalloc(pkg->conflicts_count, sizeof(compound_depend_t));
22      for (i = 0; i < pkg->conflicts_count; i++) {
23 -        conflicts->type = CONFLICTS;
24          parseDepends(conflicts, pkg->conflicts_str[i]);
25 +        conflicts->type = CONFLICTS;
26          free(pkg->conflicts_str[i]);
27          conflicts++;
28      }
29 -- 
30 1.9.1
31