python: Add packages required for google api v3
[opendreambox.git] / meta-opendreambox / recipes-devtools / python / python-httplib2_0.9.1.bb
1 DESCRIPTION = "A comprehensive HTTP client library"
2 HOMEPAGE = "https://code.google.com/p/httplib2/"
3 SECTION = "devel/python"
4 LICENSE = "MIT"
5 LIC_FILES_CHKSUM = "file://PKG-INFO;md5=6010ef08fe55505a5e11ad1f1fb90fb8"
6
7 SRCNAME = "httplib2"
8
9 SRC_URI = "https://pypi.python.org/packages/source/h/${SRCNAME}/${SRCNAME}-${PV}.tar.gz"
10
11 SRC_URI[md5sum] = "c49590437e4c5729505d034cd34a8528"
12 SRC_URI[sha256sum] = "bc6339919a5235b9d1aaee011ca5464184098f0c47c9098001f91c97176583f5"
13
14 S = "${WORKDIR}/${SRCNAME}-${PV}"
15
16 inherit setuptools
17
18 do_install_append() {
19         perm_files=`find "${D}${PYTHON_SITEPACKAGES_DIR}/" -name "top_level.txt"`
20         for f in $perm_files; do
21                 chmod 644 "${f}"
22         done
23 }