update dm7080 hardware drivers (frontend / demux was broken in 20170409)
[opendreambox.git] / meta-opendreambox / recipes-dreambox / dreambox / dreambox-dvbincludes_1.1.bb
1 SUMMARY = "dbox2/dreambox compatible header files"
2 LICENSE = "GPLv2+"
3 LIC_FILES_CHKSUM = "file://dbox/avs_core.h;beginline=1;endline=21;md5=b2ab401756a0768647ae13acb2e325ab"
4
5 SRC_URI = "http://sources.dreamboxupdate.com/snapshots/include2.tar.gz"
6 SRC_URI[md5sum] = "9d236095a88d7ce9f3bf0503ee5237d6"
7 SRC_URI[sha256sum] = "739bc35bccdb1e4c6e14b77ab86808354eb6fd75434d3bd6236f3b3346805e02"
8
9 S = "${WORKDIR}/include"
10
11 # avs_core.h and saa7126_core.h are obsolete, but
12 # libtuxtxt currently doesn't compile without them.
13 INPUT_FILES = " \
14         dbox/fp.h \
15         dbox/lcd-ks0713.h \
16         dbox/avs_core.h \
17         dbox/saa7126_core.h \
18 "
19
20 do_install() {
21         install -d ${D}${includedir}/dbox
22         for f in ${INPUT_FILES}; do
23                 install -m 0644 $f ${D}${includedir}/$f
24         done
25 }