gst-plugins-good: compile fix
[opendreambox.git] / meta-opendreambox / recipes-multimedia / gstreamer / gst-plugins-good_0.10.31.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5                     file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f \
6                     file://gst/replaygain/rganalysis.c;beginline=1;endline=23;md5=b60ebefd5b2f5a8e0cab6bfee391a5fe"
7
8 DEPENDS += "cdparanoia orc orc-native"
9 DEPENDS += "gst-plugins-base"
10
11 PR = "r0"
12 GIT_PV = ""
13
14 SRCREV = "967fc61715fa854dacaa200069437fe57d4d8390"
15
16 EXTRA_OECONF = "--enable-orc --disable-esd --disable-aasink"
17
18 inherit autotools pkgconfig gettext git-project
19
20 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
21
22 SRC_URI += " \
23         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
24         file://0001-accept-substream-syncwords-DTS-HD.patch \
25         ${@base_version_less_or_equal('DREAMBOX_KERNEL_VERSION', '2.6.18', 'file://v4l-compile-fix-old-kernel.patch', '', d)} \
26 "
27
28 do_common_update() {
29         cd ${S}
30         # Make sure we have common
31         if test ! -f common/gst-autogen.sh;
32         then
33           echo "+ Setting up common submodule"
34           git submodule init
35         fi
36         git submodule update
37
38         # source helper functions
39         if test ! -f common/gst-autogen.sh;
40         then
41           echo There is something wrong with your source tree.
42           echo You are missing common/gst-autogen.sh
43           exit 1
44         fi
45         . common/gst-autogen.sh
46         # install pre-commit hook for doing clean commits
47         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
48         then
49             rm -f .git/hooks/pre-commit
50             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
51         fi
52
53         # GNU gettext automake support doesn't get along with git.
54         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
55         autopoint || touch config.rpath
56         touch -t 200001010000 po/gst-plugins-base-0.10.pot
57 }
58 addtask common_update after do_unpack before do_patch
59
60 do_configure_prepend() {
61         # This m4 file contains nastiness which conflicts with libtool 2.2.2
62         rm ${S}/m4/lib-link.m4 || true
63 }
64
65 require mips-only.inc