gst-plugin-dvbmediasink: push srcrev for vp8 support
[opendreambox.git] / meta-opendreambox / recipes-multimedia / gstreamer / gst-plugins-ugly / orc.m4-fix-location-of-orcc-when-cross-compiling.patch
1 From 114ec19a882192dfcb5f71bb12c811d0a3b7f324 Mon Sep 17 00:00:00 2001
2 From: Andreas Oberritter <obi@opendreambox.org>
3 Date: Tue, 8 May 2012 17:27:55 +0200
4 Subject: [PATCH] orc.m4: fix location of orcc when cross-compiling
5
6 * Prepend PKG_CONFIG_SYSROOT to orcc, so configure doesn't
7   accidentially use an incompatible version of orcc installed
8   on the build system.
9
10 Signed-off-by: Andreas Oberritter <obi@opendreambox.org>
11 ---
12  m4/orc.m4 |    4 +++-
13  1 file changed, 3 insertions(+), 1 deletion(-)
14
15 diff --git a/common/m4/orc.m4 b/common/m4/orc.m4
16 index 26b2459..81b111e 100644
17 --- a/common/m4/orc.m4
18 +++ b/common/m4/orc.m4
19 @@ -3,6 +3,8 @@ dnl pkg-config-based checks for Orc
20  dnl specific:
21  dnl ORC_CHECK([REQUIRED_VERSION])
22  
23 +m4_pattern_allow(PKG_CONFIG_SYSROOT_DIR)
24 +
25  AC_DEFUN([ORC_CHECK],
26  [
27    ORC_REQ=ifelse([$1], , "0.4.6", [$1])
28 @@ -24,7 +26,7 @@ AC_DEFUN([ORC_CHECK],
29        HAVE_ORC=yes
30        if test "x$ORCC" = "x" ; then
31          AC_MSG_CHECKING(for usable orcc)
32 -        ORCC=`$PKG_CONFIG --variable=orcc orc-0.4`
33 +        ORCC=$PKG_CONFIG_SYSROOT_DIR`$PKG_CONFIG --variable=orcc orc-0.4`
34          dnl check whether the orcc found by pkg-config can be run from the build environment
35          dnl if this is not the case (e.g. when cross-compiling) fall back to orcc from PATH
36          AS_IF([$ORCC --version 1> /dev/null 2> /dev/null], [], [ORCC=`which orcc`])
37 -- 
38 1.7.9.5
39