gstreamer: push to current 0.10 git, backported hls fixes
[opendreambox.git] / meta-opendreambox / recipes-multimedia / gstreamer / gst-plugins-ugly_0.10.19.1.bb
1 require recipes-multimedia/gstreamer/gst-plugins.inc
2
3 LICENSE = "GPLv2+ & LGPLv2.1+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=a6f89e2100d9b6cdffcea4f398e37343 \
5                     file://common/coverage/coverage-report.pl;beginline=2;endline=17;md5=622921ffad8cb18ab906c56052788a3f"
6
7 DEPENDS += "gst-plugins-base libid3tag libmad mpeg2dec liba52 lame libcdio opencore-amr"
8
9 EXTRA_OECONF += "--enable-orc"
10
11 PR = "r3"
12 GIT_PV = ""
13
14 SRCREV = "9afc696e5fa9fb980e02df5637f022796763216f"
15
16 inherit autotools pkgconfig gettext git-project
17
18 SRC_URI = "git://anongit.freedesktop.org/gstreamer/${PN}"
19
20 SRC_URI += " \
21         file://orc.m4-fix-location-of-orcc-when-cross-compiling.patch \
22 "
23
24 do_common_update() {
25         cd ${S}
26         # Make sure we have common
27         if test ! -f common/gst-autogen.sh;
28         then
29           echo "+ Setting up common submodule"
30           git submodule init
31         fi
32         git submodule update
33
34         # source helper functions
35         if test ! -f common/gst-autogen.sh;
36         then
37           echo There is something wrong with your source tree.
38           echo You are missing common/gst-autogen.sh
39           exit 1
40         fi
41         . common/gst-autogen.sh
42         # install pre-commit hook for doing clean commits
43         if test ! \( -x .git/hooks/pre-commit -a -L .git/hooks/pre-commit \);
44         then
45             rm -f .git/hooks/pre-commit
46             ln -s ../../common/hooks/pre-commit.hook .git/hooks/pre-commit
47         fi
48
49         # GNU gettext automake support doesn't get along with git.
50         # https://bugzilla.gnome.org/show_bug.cgi?id=661128
51         autopoint || touch config.rpath
52         touch -t 200001010000 po/gst-plugins-base-0.10.pot
53 }
54 addtask common_update after do_unpack before do_patch
55
56 do_configure_prepend() {
57         # This m4 file contains nastiness which conflicts with libtool 2.2.2
58         rm ${S}/m4/lib-link.m4 || true
59 }
60
61 require mips-only.inc