opendreambox.conf: bump distro version to 2.4
[opendreambox.git] / meta-opendreambox / recipes-support / fcgi / fcgi_2.4.0.bb
1 DESCRIPTION = "FastCGI is a protocol for interfacing interactive programs with a web server."
2 HOMEPAGE = "http://www.fastcgi.com"
3 LICENSE = "OML"
4 LIC_FILES_CHKSUM = "file://LICENSE.TERMS;md5=e3aacac3a647af6e7e31f181cda0a06a"
5
6 SRC_URI = "http://fossies.org/linux/www/${BP}.tar.gz \
7            file://Fix_EOF_not_declared_issue.patch \
8            file://add_foreign_to_AM_INIT_AUTOMAKE.patch \
9 "
10 SRC_URI[md5sum] = "d15060a813b91383a9f3c66faf84867e"
11 SRC_URI[sha256sum] = "66fc45c6b36a21bf2fbbb68e90f780cc21a9da1fffbae75e76d2b4402d3f05b9"
12
13 inherit autotools
14
15 PACKAGES =+ "${PN}-bin lib${PN} lib${PN}++"
16
17 RDEPENDS_${PN} = "${PN}-bin lib${PN} lib${PN}++"
18
19 FILES_${PN}-bin = "${bindir}/cgi-fcgi"
20 FILES_lib${PN} = "${libdir}/libfcgi${SOLIBS}"
21 FILES_lib${PN}++ = "${libdir}/libfcgi++${SOLIBS}"
22
23 ALLOW_EMPTY_${PN} = "1"
24
25 PARALLEL_MAKE = ""