angstrom: add OABI version for armv4 machines
[openembedded.git] / packages / gstreamer / gst-plugins_0.8.6.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Plugins for GStreamer"
3 SECTION = "x11/libs"
4 PRIORITY = "optional"
5 PR = "r2"
6
7 DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
8
9 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
10            file://try-esdsink.patch;patch=1 \
11            file://lame-autoconf.patch;patch=1"
12
13 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
14                 --disable-artsc --disable-libfame --disable-sdl --disable-shout2 \
15                 --disable-gnome_vfs --disable-gconf --disable-libcaca"
16
17 inherit autotools pkgconfig gconf
18
19 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
20
21 LIBV = "0.8"
22
23 plugin_postinst() {
24         if [ x"$D" = "x" ]; then
25                 gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
26         fi
27 }
28
29 PACKAGES_DYNAMIC = "gst-plugin-*"
30
31 python populate_packages_prepend () {
32         gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
33         postinst = bb.data.getVar('plugin_postinst', d, 1)
34
35         do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
36         do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
37 }
38
39 do_stage() {
40         autotools_stage_includes
41         while read a b; do
42                 oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
43         done <<EOF
44 . interfaces-0.8
45 audio audio
46 audio audiofilter
47 gconf gconf-0.8
48 idct idct
49 media-info media-info-0.8
50 play play-0.8
51 resample resample
52 riff riff
53 video video
54 xwindowlistener xwindowlistener
55 EOF
56 }