make compatible with python 2.2
[bitbake.git] / bin / utils / itertools.py
1 """itertools appeared in Python 2.3 - this module mimicks it (partly)"""
2
3 from __future__ import generators
4
5 def cycle( sequence ):
6     """Return a cyclic generator iterating over sequence"""
7     while True:
8         for element in sequence:
9             yield element
10