drop shebangs from lib/bb scripts
[bitbake.git] / lib / bb / providers.py
1 # ex:ts=4:sw=4:sts=4:et
2 # -*- tab-width: 4; c-basic-offset: 4; indent-tabs-mode: nil -*-
3 #
4 # Copyright (C) 2003, 2004  Chris Larson
5 # Copyright (C) 2003, 2004  Phil Blundell
6 # Copyright (C) 2003 - 2005 Michael 'Mickey' Lauer
7 # Copyright (C) 2005        Holger Hans Peter Freyther
8 # Copyright (C) 2005        ROAD GmbH
9 # Copyright (C) 2006        Richard Purdie
10 #
11 # This program is free software; you can redistribute it and/or modify
12 # it under the terms of the GNU General Public License version 2 as
13 # published by the Free Software Foundation.
14 #
15 # This program is distributed in the hope that it will be useful,
16 # but WITHOUT ANY WARRANTY; without even the implied warranty of
17 # MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
18 # GNU General Public License for more details.
19 #
20 # You should have received a copy of the GNU General Public License along
21 # with this program; if not, write to the Free Software Foundation, Inc.,
22 # 51 Franklin Street, Fifth Floor, Boston, MA 02110-1301 USA.
23
24 import os, re
25 from bb import data, utils
26 import bb
27
28 class NoProvider(Exception):
29     """Exception raised when no provider of a build dependency can be found"""
30
31 class NoRProvider(Exception):
32     """Exception raised when no provider of a runtime dependency can be found"""
33
34 def findBestProvider(pn, cfgData, dataCache, pkg_pn = None, item = None):
35     """
36     If there is a PREFERRED_VERSION, find the highest-priority bbfile
37     providing that version.  If not, find the latest version provided by
38     an bbfile in the highest-priority set.
39     """
40     if not pkg_pn:
41         pkg_pn = dataCache.pkg_pn
42
43     files = pkg_pn[pn]
44     priorities = {}
45     for f in files:
46         priority = dataCache.bbfile_priority[f]
47         if priority not in priorities:
48             priorities[priority] = []
49         priorities[priority].append(f)
50     p_list = priorities.keys()
51     p_list.sort(lambda a, b: a - b)
52     tmp_pn = []
53     for p in p_list:
54         tmp_pn = [priorities[p]] + tmp_pn
55
56     preferred_file = None
57
58     localdata = data.createCopy(cfgData)
59     bb.data.setVar('OVERRIDES', "%s:%s" % (pn, data.getVar('OVERRIDES', localdata)), localdata)
60     bb.data.update_data(localdata)
61
62     preferred_v = bb.data.getVar('PREFERRED_VERSION_%s' % pn, localdata, True)
63     if preferred_v:
64         m = re.match('(.*)_(.*)', preferred_v)
65         if m:
66             preferred_v = m.group(1)
67             preferred_r = m.group(2)
68         else:
69             preferred_r = None
70
71         for file_set in tmp_pn:
72             for f in file_set:
73                 pv,pr = dataCache.pkg_pvpr[f]
74                 if preferred_v == pv and (preferred_r == pr or preferred_r == None):
75                     preferred_file = f
76                     preferred_ver = (pv, pr)
77                     break
78             if preferred_file:
79                 break;
80         if preferred_r:
81             pv_str = '%s-%s' % (preferred_v, preferred_r)
82         else:
83             pv_str = preferred_v
84         itemstr = ""
85         if item:
86             itemstr = " (for item %s)" % item
87         if preferred_file is None:
88             bb.msg.note(1, bb.msg.domain.Provider, "preferred version %s of %s not available%s" % (pv_str, pn, itemstr))
89         else:
90             bb.msg.debug(1, bb.msg.domain.Provider, "selecting %s as PREFERRED_VERSION %s of package %s%s" % (preferred_file, pv_str, pn, itemstr))
91
92     del localdata
93
94     # get highest priority file set
95     files = tmp_pn[0]
96     latest = None
97     latest_p = 0
98     latest_f = None
99     for file_name in files:
100         pv,pr = dataCache.pkg_pvpr[file_name]
101         dp = dataCache.pkg_dp[file_name]
102
103         if (latest is None) or ((latest_p == dp) and (utils.vercmp(latest, (pv, pr)) < 0)) or (dp > latest_p):
104             latest = (pv, pr)
105             latest_f = file_name
106             latest_p = dp
107     if preferred_file is None:
108         preferred_file = latest_f
109         preferred_ver = latest
110
111     return (latest,latest_f,preferred_ver, preferred_file)
112
113 #
114 # RP - build_cache_fail needs to move elsewhere
115 #
116 def filterProviders(providers, item, cfgData, dataCache, build_cache_fail = {}):
117     """
118     Take a list of providers and filter/reorder according to the 
119     environment variables and previous build results
120     """
121     eligible = []
122     preferred_versions = {}
123
124     # Collate providers by PN
125     pkg_pn = {}
126     for p in providers:
127         pn = dataCache.pkg_fn[p]
128         if pn not in pkg_pn:
129             pkg_pn[pn] = []
130         pkg_pn[pn].append(p)
131
132     bb.msg.debug(1, bb.msg.domain.Provider, "providers for %s are: %s" % (item, pkg_pn.keys()))
133
134     for pn in pkg_pn.keys():
135         preferred_versions[pn] = bb.providers.findBestProvider(pn, cfgData, dataCache, pkg_pn, item)[2:4]
136         eligible.append(preferred_versions[pn][1])
137
138
139     for p in eligible:
140         if p in build_cache_fail:
141             bb.msg.debug(1, bb.msg.domain.Provider, "rejecting already-failed %s" % p)
142             eligible.remove(p)
143
144     if len(eligible) == 0:
145         bb.msg.error(bb.msg.domain.Provider, "no eligible providers for %s" % item)
146         return 0
147
148
149     # If pn == item, give it a slight default preference
150     # This means PREFERRED_PROVIDER_foobar defaults to foobar if available
151     for p in providers:
152         pn = dataCache.pkg_fn[p]
153         if pn != item:
154             continue
155         (newvers, fn) = preferred_versions[pn]
156         if not fn in eligible:
157             continue
158         eligible.remove(fn)
159         eligible = [fn] + eligible
160
161     # look to see if one of them is already staged, or marked as preferred.
162     # if so, bump it to the head of the queue
163     for p in providers:
164         pn = dataCache.pkg_fn[p]
165         pv, pr = dataCache.pkg_pvpr[p]
166
167         stamp = '%s.do_populate_staging' % dataCache.stamp[p]
168         if os.path.exists(stamp):
169             (newvers, fn) = preferred_versions[pn]
170             if not fn in eligible:
171                 # package was made ineligible by already-failed check
172                 continue
173             oldver = "%s-%s" % (pv, pr)
174             newver = '-'.join(newvers)
175             if (newver != oldver):
176                 extra_chat = "%s (%s) already staged but upgrading to %s to satisfy %s" % (pn, oldver, newver, item)
177             else:
178                 extra_chat = "Selecting already-staged %s (%s) to satisfy %s" % (pn, oldver, item)
179
180             bb.msg.note(2, bb.msg.domain.Provider, "%s" % extra_chat)
181             eligible.remove(fn)
182             eligible = [fn] + eligible
183             break
184
185     return eligible
186
187 def getRuntimeProviders(dataCache, rdepend):
188     """
189     Return any providers of runtime dependency
190     """
191     rproviders = []
192
193     if rdepend in dataCache.rproviders:
194        rproviders += dataCache.rproviders[rdepend]
195
196     if rdepend in dataCache.packages:
197         rproviders += dataCache.packages[rdepend]
198
199     if rproviders:
200         return rproviders
201
202     # Only search dynamic packages if we can't find anything in other variables
203     for pattern in dataCache.packages_dynamic:
204         regexp = re.compile(pattern)
205         if regexp.match(rdepend):
206             rproviders += dataCache.packages_dynamic[pattern]
207
208     return rproviders