openssl: replace full recipe for 0.9.8 with a stripped-down libssl0.9.8 recipe contai...
[opendreambox.git] / meta-opendreambox / recipes-connectivity / madwifi / madwifi-ng / fix-module-autoload.patch
1 --- a/net80211/ieee80211_linux.c        2012-01-27 22:35:51.890501496 +0100
2 +++ b/net80211/ieee80211_linux.c        2012-01-27 22:35:03.806502081 +0100
3 @@ -405,7 +405,7 @@
4  int
5  ieee80211_load_module(const char *modname)
6  {
7 -#ifdef CONFIG_KMOD
8 +#if defined(CONFIG_KMOD) || LINUX_VERSION_CODE > KERNEL_VERSION(2,6,28)
9         int rv;
10         rv = request_module(modname);
11         if (rv < 0)