ltrace: use PACKAGECONFIG for libunwind
[opendreambox.git] / meta-opendreambox / recipes-devtools / ltrace / ltrace_git.bb
1 SUMMARY = "Tracks runtime library calls in dynamically linked programs"
2 HOMEPAGE = "http://www.ltrace.org/"
3 SECTION = "devel"
4 LICENSE = "GPLv2"
5 LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
6 DEPENDS = "binutils elfutils"
7 SRCREV = "d66c8b11facf570d96a49c1b812b90101c62023b"
8 PV = "0.7.2"
9
10 SRC_URI = "git://anonscm.debian.org/collab-maint/ltrace.git \
11            file://0001-linux-uclibc-targets-should-be-handled-by-linux-gnu-.patch"
12
13 inherit autotools git-project
14
15 EXTRA_OECONF = "--disable-werror"
16
17 do_configure_prepend() {
18     # from autogen.sh
19     mkdir -p config/autoconf config/m4
20 }
21
22 PACKAGECONFIG ??= "${LIBUNWIND}"
23 PACKAGECONFIG[libunwind] = "--with-libunwind,--without-libunwind,libunwind"
24
25 LIBUNWIND = "libunwind"
26 LIBUNWIND_arm = ""
27 LIBUNWIND_libc-uclibc = ""