enigma2: remove modem plugin and related scripts
[opendreambox.git] / meta-opendreambox / recipes-dreambox / dreambox / dreambox-compat_1.0.bb
1 SUMMARY = "Dreambox compatibility links"
2 SECTION = "base"
3 LICENSE = "MIT"
4 LIC_FILES_CHKSUM = "file://${OPENDREAMBOX_BASE}/LICENSE;md5=ed920ea8b6701825484d079e87a3a73a"
5 PRIORITY = "required"
6
7 inherit allarch
8
9 do_install() {
10         install -d ${D}${base_libdir}
11         ln -sf libcrypto.so.0.9.8 ${D}${base_libdir}/libcrypto.so.0.9.7
12         ln -sf libgcc_s.so.1 ${D}${base_libdir}/libgcc_s_nof.so.1
13         install -d ${D}${libdir}
14         ln -sf libdvbsi++.so.1 ${D}${libdir}/libdvbsi++.so.0
15         ln -sf libgif.so.4 ${D}${libdir}/libungif.so.4
16         ln -sf libjpeg.so.62 ${D}${libdir}/libjpeg.so.8
17         ln -sf libssl.so.0.9.8 ${D}${libdir}/libssl.so.0.9.7
18         ln -sf libpython2.7.so.1.0 ${D}${libdir}/libpython2.6.so.1.0
19 }
20
21 PACKAGES = "${PN}"