enigma2: don't depend on alsa-conf (there's alsa-conf-base)
[opendreambox.git] / meta-opendreambox / recipes-dreambox / enigma2 / enigma2-common.inc
1 SUMMARY = "Framebuffer-based digital media application"
2 LICENSE = "Proprietary"
3
4 PACKAGES += "${PN}-meta"
5
6 RDEPENDS_${PN} += " \
7         e2fsprogs-e2fsck \
8         e2fsprogs-mke2fs \
9         glibc-gconv-iso8859-15 \
10         hdparm \
11         python-codecs \
12         python-core \
13         python-crypt \
14         python-fcntl \
15         python-lang \
16         python-netclient \
17         python-netserver \
18         python-pickle \
19         python-re \
20         python-shell \
21         python-twisted-core \
22         python-twisted-web \
23         python-xml \
24         python-zopeinterface \
25         sdparm \
26         util-linux-blkid \
27         util-linux-sfdisk \
28 "
29
30 # Qt won't start without this fonts directory.
31 do_install_append() {
32         install -d ${D}${libdir}/fonts
33 }
34
35 FILES_${PN} += "${datadir}/fonts ${datadir}/keymaps ${libdir}/fonts ${libdir}/libopen.so"
36 FILES_${PN}-meta = "${datadir}/meta"
37
38 require enigma2-core-plugins.inc