tpm-ca: new recipe
[opendreambox.git] / meta-opendreambox / recipes-dreambox / recovery / recovery_1.0.bb
1 SUMMARY = "Command-line tools to flash and recover your Dreambox"
2 HOMEPAGE = "http://dreamboxupdate.com/"
3 LICENSE = "CLOSED"
4 SRCREV = "${@opendreambox_srcrev('f6d9de6dc38272d83f19f63afe874e1cb58a8c61', d)}"
5 SRCREV_dm7080 = "${@opendreambox_srcrev('46b9204f5f9612a2e515b43454f67b41531a3bf5', d)}"
6
7 SRC_URI_append = ";branch=${BRANCH}"
8
9 inherit opendreambox-git
10
11 do_install() {
12     oe_runmake install DESTDIR=${D}
13 }
14
15 PACKAGES =+ "flash-scripts"
16
17 PACKAGE_ARCH = "${MACHINE_ARCH}"
18
19 RDEPENDS_${PN} = " \
20     e2fsprogs-mke2fs \
21     flash-scripts \
22     gpgv \
23     parted \
24     pigz \
25     util-linux-mount \
26 "
27 RDEPENDS_flash-scripts = " \
28     coreutils-realpath \
29     fastboot \
30     mkbootblob \
31     util-linux-sfdisk \
32 "
33
34 FILES_flash-scripts = " \
35     ${sbindir}/flash-rescue \
36     ${sbindir}/flash-kernel \
37     ${sbindir}/flash-ssbl \
38     ${sbindir}/librecovery \
39     ${sbindir}/select-boot-source \
40     ${sbindir}/to-the-rescue \
41 "
42
43 BRANCH = "master"
44 BRANCH_dm7080 = "dm7080"
45
46 COMPATIBLE_MACHINE = "^(dm7080)$"