sispmctl: inherit pkgconfig
[opendreambox.git] / meta-opendreambox / recipes-dreambox / tuxcom / tuxbox-tuxcom-32bpp.bb
1 SUMMARY = "TuxCom for 800/7025/8000/32bit framebuffer HD Autosize"
2 LICENSE = "Proprietary"
3 LIC_FILES_CHKSUM = "file://tuxcom.c;endline=23;md5=33c69eb2b4a436ea9e00355b66c21dd9"
4 DEPENDS = "freetype"
5 RDEPENDS_${PN} = "enigma2"
6 SRCDATE = "20070410"
7 PV = "1.16+cvs${SRCDATE}"
8
9 SRC_URI = "cvs://anoncvs@cvs.tuxbox.org/cvs/tuxbox;module=apps/tuxbox/plugins/tuxcom;method=ext \
10         file://makefiles.diff \
11         file://add_font.diff \
12         file://32bpp.diff \
13         file://add_e2_plugin.diff \
14         file://largefile.diff \
15         file://support_newer_freetype.diff \
16         file://fix_smstext.diff \
17 "
18
19 S = "${WORKDIR}/tuxcom"
20
21 inherit autotools
22
23 EXTRA_OECONF = "--with-target=native"
24
25 do_configure_prepend() {
26         touch ${S}/python/__init__.py
27 }
28
29 FILES_${PN} = "${bindir}/tuxcom ${libdir}/enigma2 /etc/tuxcom ${datadir}/fonts/pakenham.ttf"
30
31 CPPFLAGS += "-DHAVE_DREAMBOX_HARDWARE -DDREAMBOX"