submodules: update meta-qt5 url from git://github.com to https://github.com
[opendreambox.git] / meta-opendreambox / recipes-multimedia / dvd+rw-tools / dvd+rw-tools_7.1.bb
1 SUMMARY = "tools to write DVDs"
2 LICENSE = "GPLv2"
3 LIC_FILES_CHKSUM = "file://LICENSE;md5=8ca43cbc842c2336e835926c2166c28b"
4 DEPENDS += "m4-native"
5 RDEPENDS_${PN} += "cdrkit"
6 SRC_URI = "http://fy.chalmers.se/~appro/linux/DVD+RW/tools/dvd+rw-tools-${PV}.tar.gz \
7            file://01-growisofs-pioneer.dpatch;apply=yes \
8            file://02-growisofs-manpage.dpatch;apply=yes \
9            file://03-growisofs-dvd-dl.dpatch;apply=yes \
10            file://04-kfreebsd.dpatch;apply=yes \
11            file://07-beeping.dpatch;apply=yes \
12            file://08-cdrkit-code.dpatch;apply=yes \
13            file://09-cdrkit-doc.dpatch;apply=yes \
14            file://10-includes.dpatch;apply=yes \
15           "
16
17 do_configure() {
18     m4 -DOS=Linux Makefile.m4 >Makefile
19 }
20
21 do_compile() {
22     oe_runmake CC="${CC}" CXX="${CXX}" dvd+rw-tools
23 }
24
25 do_install() {
26     install -d ${D}/usr/bin
27     install -m 755 ${S}/growisofs ${D}/usr/bin
28     install -m 755 ${S}/dvd+rw-booktype ${D}/usr/bin
29     install -m 755 ${S}/dvd+rw-format ${D}/usr/bin
30     install -m 755 ${S}/dvd+rw-mediainfo ${D}/usr/bin
31     install -m 755 ${S}/dvd-ram-control ${D}/usr/bin
32 }
33
34
35 SRC_URI[md5sum] = "8acb3c885c87f6838704a0025e435871"
36 SRC_URI[sha256sum] = "f8d60f822e914128bcbc5f64fbe3ed131cbff9045dca7e12c5b77b26edde72ca"